Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Purchase Order not printing
12-21-2013, 06:33 AM
Post: #1
Purchase Order not printing
Hello,
First of all, I would like to thank the WebERP team for developing such an excellent product.

I was trying WebERP for the first time without any real data for now. I found that I couldn't really print the PDF output for Purchase Orders. After creating a order, and entering the required items, price, quantity, and therefore processing the order to print it at the end. But when I click OK, the script starts to run and never push any PDF for download.

My System has latest apache with PHP 5.3 and MySQL 5.5. First I thought it might be some problem with my PHP or something, but later I browsed to the online demo WebERP has on the main website (http://www.weberp.org/weberp/) and then tried to Print an existing purchase order from there. But I couldn't. Same problem. Script fails to produce any PDF file and does not through any exception errors.

Regards,
Saiful
Find all posts by this user
Quote this message in a reply
12-21-2013, 03:22 PM
Post: #2
RE: Purchase Order not printing
Can you check that you have a directory under companies for the company you are using call FormDesigns - if not copy it over from the weberpdemo company to your new company

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
12-21-2013, 07:02 PM
Post: #3
RE: Purchase Order not printing
Contents of companies folder

1. weberp_erp
2. weberpdemo

Both folders have a common "FormDesigns' folder inside them. FormDesigns folder has 4 XML files inside it. My WebERP version is 4.11.2

Problem still exists.

Regards,
Saiful Alam
Find all posts by this user
Quote this message in a reply
12-29-2013, 12:31 PM (This post was last modified: 12-29-2013 12:55 PM by DonGrames.)
Post: #4
RE: Purchase Order not printing
I just upgraded to 4.11.2 from 4.10.1, and also cannot reprint or print a PO.
A pdf file is generated and has content, but in Adobe and Okular(KDE) a blank page is shown in landscape, it should be portrait.
I even tried using PO_PDFPurchOrder.php and PO_PDFOrderPageHeader.inc from 4.10.1
and it stays the same.
When I view the generated page in a text viewer it has content, about 11.5k

*** Found the error with my old PurchaseOrder.xml in the formdesigns directory.
Thanks for a great program.
Find all posts by this user
Quote this message in a reply
12-29-2013, 03:21 PM
Post: #5
RE: Purchase Order not printing
Sorry Don - was just looking into this - what was it that turned out to be the source of the problem?
Did you have a PurchaseOrder.xml file under your companies/YourCompany/FormDesigns/ directory?

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
12-29-2013, 11:55 PM (This post was last modified: 12-30-2013 12:15 AM by DonGrames.)
Post: #6
RE: Purchase Order not printing
Hi Phil,
There were some entry changes moving from the old PurchaseOrder.xml to the new version as I did copy the company folder over from the old installation when I upgraded.
The new xml file from 4.11.2 swapped the order of CompanyName and TaxAuthority.
It also removed DeliveryAddress6, and added SupplierAddress5.
Hope this helps.

Don
Hi Phil,
There was one other change I missed.
Paper size was changed from letter to Letter.

Don
Find all posts by this user
Quote this message in a reply
12-30-2013, 11:03 AM
Post: #7
RE: Purchase Order not printing
Hi Don,
Sorry to be a bit slow on the up-take .... do you mean you had modified your PurchaseOrder.xml and you needed to redo those changes in the new default PurchaseOrder.xml or that your existing PurchaseOrder.xml no longer worked with the new version because fields had been removed?

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
12-30-2013, 11:39 AM
Post: #8
RE: Purchase Order not printing
Hi Phil,
I reused the old PurchaseOrder.xml when I copied my company directory over.
Those changes were what I noticed. In the script file includes/PDFStarter.php
the case for Letter used to be letter with lower case l. This was probably the cause of my not being able to print to pdf. The other fields were what changed from the old PurchaseOrder.xml to the new.

I never did modify this file, but the changes were made in the source.

Don

(12-30-2013 11:03 AM)phil Wrote:  Hi Don,
Sorry to be a bit slow on the up-take .... do you mean you had modified your PurchaseOrder.xml and you needed to redo those changes in the new default PurchaseOrder.xml or that your existing PurchaseOrder.xml no longer worked with the new version because fields had been removed?
Find all posts by this user
Quote this message in a reply
12-30-2013, 02:36 PM
Post: #9
RE: Purchase Order not printing
Ah - ok got it thanks for explaining Don ... no doubt others will hit the same snag.
So the guts then is - make sure to use the new FormDesigns/PurchaseOrder,xml even when upgrading an existing install.

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
12-30-2013, 07:41 PM
Post: #10
RE: Purchase Order not printing
Received this from Tim :
Quote:The original posters problem was with his browser settings as the
problem continued on the demo.

Have sorted that privately.

Tim

Phil Daintree
webERP Admin
Logic Works Ltd
http://www.logicworks.co.nz
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)